Symptom
The preboot diagnostics is embedded within the BIOS and launched by the BIOS internally. Preboot diagnostic tests your hardware without using the operating system. The preboot diagnostics provides options for particular devices or device groups allowing you to:
- Run tests automatically or in an interactive mode.
- Repeat tests.
- Display or save test results.
- Run thorough tests to introduce additional test options to provide extra information about the failed devices.
- View status messages that inform you if tests are completed successfully.
- View error messages that inform you of problems encountered during testing.
Works with: SupportAssist Pre-Boot System Performance Check and other preboot system assessments such as ePSA or PSA.
NOTE: Some tests for specific devices require user interaction. Always ensure that you are present at the computer terminal when the diagnostic tests are performed.
NOTE: The instructions to enter the preboot diagnostic utility and the interface may vary slightly. For product-specific information, see the
user manual of your Dell computer.
Cause
You may experience a time when your computer may not boot into the operating system. File corruption, a virus, spyware, malware, or a hardware failure could cause this issue. Using the preboot diagnostic test helps identify a hardware failure.
Resolution
- Turn on your computer.
- At the Dell logo, press the F12 key several times until the One Time Boot Menu appears.
- On the boot menu screen, select the Diagnostics option and press Enter (Figure 1).
![One Time Boot Menu](https://supportkb.dell.com/img/ka06P000000Y3YvQAK/ka06P000000Y3YvQAK_en_US_1.png)
Figure 1: Illustration of the One Time Boot Menu. (Image is in English only)
- The diagnostic test begins.
NOTE: The mouse is not active during testing.
NOTE: On Dell laptops, user response is required during the LCD test.
- To run a diagnostic test on a specific device, press Esc and click Yes to stop the diagnostic test.
- Click the arrow on the lower-right corner to go to the page listing. The detected items are listed (Figure 2).
![Screenshot of the preboot system assessment](https://supportkb.dell.com/img/ka06P000000Y3YvQAK/ka06P000000Y3YvQAK_en_US_2.png)
Figure 2: Screenshot of the preboot system assessment. (Image is in English only).
- Select a device to run the test (Figure 3).
![Screenshot of hardware components detected in the preboot system assessment](https://supportkb.dell.com/img/ka06P000000Y3YvQAK/ka06P000000Y3YvQAK_en_US_3.png)
Figure 3: Screenshot of hardware components detected in the preboot system assessment. (Image is in English only)
- If there are any issues, error codes are displayed. Make a note of the error code, validation code, and service tag, and then look up the error code.
NOTE: For troubleshooting steps to possibly resolve the issue, see the following articles.
Select the article which matches the error range and look up the specific error you have, and perform the troubleshooting steps.
How to Run a Preboot Diagnostics on a Dell Computer
Watch this video to learn how to use integrated preboot diagnostics to identify hardware issues on your Dell computer.
Duration: 01:34 (mm:ss)
Closed captions: Available in multiple languages. Click the CC icon, and then select the preferred language.
Affected Product
Alienware, Inspiron, Legacy Desktop Models, OptiPlex, Vostro, XPS, G Series, G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Legacy Systems, Fixed Workstations, Mobile Workstations